In Defense of Free Software: My Case Against Lenovo in Mexico

@AbrarSyed we need a tech topic.

1 Like

This is exact thing that happened when my wife purchased a lenovo Ideapad last year.

She only does some writing and basic web browsing but does so with 100+ tabs open so I sold her on the benefits of a lighter weight OS so that she could milk more performance from a cheaper system. I had also sold her on Lenovo hardware over the other brands as I had been a devout thinkpad user for the better part of a decade.So she bought the lighter weight Ideapad and she asked me to set her up with a new OS once we got home. But after setting up a copy of Arch on a USB I found that there was no obvious way to boot from USB in the boot menu.

After some research I found and disabled secure boot, but there was still no option to boot from USB. After some more searching i found that I have to actually go into Windows then into the windows configuration screen to find the option to access the BIOS and boot from alternative media.

After trying this and finally finding the option to boot from USB I was given a simple screen simply stating that booting from USB has been removed from the BIOS.

I have since decided that the machine is a waste of time and money since the little thing can barely carry the weight of the resource slug that is windows 10 and grinds to a crawl with 10 tabs open.

I am very unlikely to purchase Lenovo in the future, which makes me very sad given my love of the Thinkpad.


@asad3ainjalout How do you get the link to preview like that?

i pasted it in

lol what…wait…so do the links I post do the same thing? lol

they should lol

But I dont think they do. I looked at my HumbleBundle Freedom Sale thread, for example, it just shows a one line link. No big preview box or anything.

Calling @abrarysyed

Lol, i t depends on the spacing arround the links I think. If you put the link on its own line, it expands. Otherwise it does the whole preview and stuff. It might also have to do with what site you are linking to.
This is a link to an article in my line.
Here it is alone:

Edit: Or not… I dunno why… Maybe because it’s the main title post of the thread…

It worked for my latest post BUT I had to paste it in FIRST lol. I dont know. I dont get it either.